Jump to content
GreenSock

Search the Community

Showing results for tags 'xmlloader progress issue'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GreenSock Forums
    • GSAP
    • Banner Animation
    • Jobs & Freelance
  • Flash / ActionScript Archive
    • GSAP (Flash)
    • Loading (Flash)
    • TransformManager (Flash)

Product Groups

  • Club GreenSock
  • TransformManager

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. I am using the following: _xmlLoader = new XMLLoader(ASSETs_URL, {name:"assets", estimatedBytes:1000, maxConnections:3, onChildComplete:handleChildComplete, onComplete:handleComplete, onProgress:handleProgress}); Here is the XML: <?xml version="1.0" encoding="iso-8859-1"?> <data> <SWFLoader url="pod1.swf" name="pod1" load="true" /> <SWFLoader url="pod2.swf" name="pod2" load="true" /> <SWFLoader url="pod3.swf" name="pod3" load="true" /> <SWFLoader url="pod4.swf" name="pod4" load="true" /> </data> When onProgress is fired it initially fires for the XML document itself. So it shoots to 100% and then back to 0 for the children. I tried supplying each SWFLoader in the XML with an estimatedBytes but that didn't solve it either. Is this expected? I could not find it in the documentation.
×