Jump to content
GreenSock

Search the Community

Showing results for tags 'webaudioapi'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GreenSock Forums
    • GSAP
    • Banner Animation
    • Jobs & Freelance
  • Flash / ActionScript Archive
    • GSAP (Flash)
    • Loading (Flash)
    • TransformManager (Flash)

Product Groups

  • Club GreenSock
  • TransformManager

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi there! I’m facing some sound issues with my app and was wondering if maybe one of you guys had similar issues... I’ve attached a video link (https://www.dropbox.com/s/msth8o10mrwvqdk/sound_bug.mp4?dl=0) where you can see and hear what’s happening. The plopping is totally random and appears mostly when there is a lot of interaction with the interface (opening modals, dragging the wheel > all handled by gsap). If I set this modules do “display:none”, to have a clean interface, the sound issue does not appear. Now you would say: We need some code... The app’s code is currently a big MESS. I cannot reproduce the issue in CodePen and to be honest, I don’t want to share my complete project folder. The app uses a lot of jQuery and the DOM is very stuffed. The ‘wheel’ is an inline SVG asset. I’m currently recoding this project with vue.js to get it A LOT leaner but this will take me a while and I would love to get rid of the sound issue before that... So I’m just taking a shot here. I’m happy for any kind of advice! I’m not sure if it is actually related with gsap, or maybe the sound issue appears because of the sum of nonoptimal code, but maybe there is some little ‘fix’ out there someone of you guys know. The issue appears in every browser. On my local machine and on mobile devices (iOS more frequent than Android though). Even on the ‘brand new’ iPhone X. The app uses cordova. I’ve tried a lot of different JS sound libraries (tone.js, howler.js, ...) currently I’m using pizzicato.js. Always the same issue. Sounds are handled by the WebAudio API. If you want to see the app in action and you are using an iOS device: With the following codes you can download the app for free on the Apple App Store (codes only work once...) TJFXHHXAHP9J KA7EA96TXEEP 4RNKFN6NH39M AWMFYTJE6AYJ 3WL76FLXNRFN FHEWJ7JYLFW9 WM4WN4AHYAFK 67E3AXNMXNRY K9Y37PFEFXWR TJLLWYFP3RWF TWHFKJ9J34YF 3M9XYTRPLA9W JAWLR9EYEFAA P3HXWEW66W7T Y73LPRM939PJ Thanks!
×