Jump to content
GreenSock

Search the Community

Showing results for tags 'video time 0'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GreenSock Forums
    • GSAP
    • Banner Animation
    • Jobs & Freelance
  • Flash / ActionScript Archive
    • GSAP (Flash)
    • Loading (Flash)
    • TransformManager (Flash)

Product Groups

  • Club GreenSock
  • TransformManager

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Thank you in advance for reading. In my Player, I preLoad videos with two VideoLoader circularly from Flash Media Server. Init code as: videoLoader = new VideoLoader("flv:Y/sample", { autoPlay:true, x:150,y:200,netStream:_ns,container:this,width:200,height:150} ); videoLoader1 = new VideoLoader("flv:Y/bikes", { autoPlay:false, netStream:_ns1,container:this,width:200,height:150} ); The first loader loads a video with autoPlay=true,the second loader loads another video with autoPlay=false. When the first loader play complete, I call the second loader playVideo(). Meanwhile, let the first loader do the followings: videoLoader.unload(); videoLoader.vars.autoPlay = false; videoLoader.url = "mp4:Y/mp4.mp4"; videoLoader.load(); But two problems bother me a lot: 1.After one play circulation, the loaders return videoTime always 0. Do i have to create a new NetStream and pass it to the loader everytime? 2.Playing a .flv video preloaded would only see first few frames ,and then quickly to the end. Playing a .mp4 video preloaded was normal. I debugged into the VideoLoader's source code, _forceTime was 0. The comment says waitForRender,but how can I let the NetStream dispatch RENDER Event? Plz help!
×