Jump to content
GreenSock

rune_star

Members
  • Posts

    7
  • Joined

  • Last visited

rune_star's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Dammit... I was afraid of that! Sometimes I wonder why I love flash so much :-S If anyone know of a fix or workaround to this problem, please point me in the right direction Thanks for your help so far...
  2. 1: None of my old versions are working anymore... 2: I haven't been able to test in older players, but I've tested in Safari, Firefox and Chrome, all on mac, which sadly displays the same behaviour. 3: No re-encoding as I know the video to work from the 'old days' when everything was peachy 4: I've compiled with both the original CS5 and the new CS6, with same results... although CS6 versions are slightly heavier, kb-wise... :-S So if the problem is (another) bug in the flash player, does anyone have a fix for that? Thanks for replying so fast!
  3. Hi, I've made a microsite several months ago, that included the use of looping video with the repeat -1 method. Everything worked great, but now several months later, I have to make a change to the FLA (just minor text changes though), I publish, and suddenly the video 'pauses' slightly before the actual looping continues :-S I've tried everything, and played around with the autoplay parameter, delaying the callbacks and other far out stuff. I've now isolated the looping video feature in the attached zip file. Is it possible that something have changed in an update to the loadermax package? The video itself is perfect. It's an FLV due to an alpha channel Please help out and have a look at the enclosed zip file. Many thanks in advance... vdotest.zip
  4. Hi, I'm having trouble making a simple motionBlur work... I'm tweening a long image, and without the motionBlur, everything tweens fine, but I can't make it work when I try to apply the motionBlur. Is there a max limit to the size of objects to motionBlur? This is my error message: ArgumentError: Error #2015: Invalid BitmapData. at flash.display::BitmapData/ctor() at flash.display::BitmapData() at com.greensock.plugins::MotionBlurPlugin/onInitTween() at com.greensock::TweenLite/init() at com.greensock::TweenMax/init() at com.greensock::TweenMax/renderTime() at com.greensock.core::SimpleTimeline/renderTime() at com.greensock::TweenLite$/updateAll() I've also attached an example FLA with the objects and the code that doesn't work... Many thanks for replies in advance... motionBlur_953x581_v01.zip
  5. Even though I know that Loadermax isn't actually made for it, I've build a videoplayer that works with RTMP streaming video, and so far so good. It all finally seems to work as expected, except for one problem... The videos all stop too soon! The onComplete event is triggered about 6-9 seconds before the video is actually finished :S I've even tried omitting the onComplete listener, and 'just' used the "NetStream.Play.Stop" from the NetStatusEvent class, and the same thing happens. When I just build a player without any controls or any Loadermax, it finished the playback completely, so it must something within the onComplete event. Anybody have experience in this direction? I'm running out of time, so that's why I had to continue with my VideoLoader player which I had finished with all controls and everything. Would take me forever to start all over with Adobes bug-ridden classes :-S I have a source file for you to look at, but would rather not put it up here untill needed
  6. No prob! I came to more or less that conclusion late last night after Googling heavily for several hours But very nice to get a 'confirmation' on the subject from you... So far I've made a chunky half-breed workaround. I've managed to force the playhead ahead of the loadbar, and then display a preloader until the loadbar (and the actual loading) catch up with the desired position. The preloader then dissappear, and playing continues... means there may be some serious waiting times, but at least the 'chapter' feature now works... sort of! Thanks for the reply
  7. Hi, I'm building a videoplayer and so far everything looks good and works a treat! Great system... My problem is now that I want to have 9 'chapters' in the same video, which is about 4.20 minutes long. The chapters are represented by buttons below, and clicking them activates a 'gotoVideoTime' event. This only works if the 'goto' time isn't ahead of the actual loading, and as the video is rather long and heavy (aprox 41 mb), it's pretty obvious that sometimes the gotoVideoTime hasn't been downloaded when the button is clicked. What happens is, that the playhead will just go to the nearest downloaded part. What I want is the functionality like Youtube player, so that downloading will restart from the desired gotoVideoTime, showing a preloader or whatever untill it's ready to play that part of the video. Is this at all possible with the LoaderMax system? I've tried all kinds of workarounds, but haven't been able to find the solution yet, so any pointer in the right direction would be a BIG help Thanks!
×