Jump to content
GreenSock

richie3355

Members
  • Posts

    1
  • Joined

  • Last visited

richie3355's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. I am new to Vue/babel development. I implemented Scroll Magic and integrated the code you have pasted for disabling AMD. I am still facing some error. Can someone guide me on the issue. package.json "dependencies": { "gsap": "^2.0.0", "imports-loader": "^0.8.0", "jquery": "^3.3.1", "scrollmagic": "^2.0.5", "vue": "^2.5.16", "vue-body-class": "^2.0.0-beta.2", "vue-router": "^3.0.1" }, "devDependencies": { "@vue/cli-plugin-babel": "^3.0.0-beta.11", "@vue/cli-service": "^3.0.0-beta.11", "babel-core": "^6.22.1", "babel-loader": "^7.1.4", "css-loader": "^0.28.11", "node-sass": "^4.9.0", "postcss-loader": "^2.1.5", "sass-loader": "^7.0.1", "vue-loader": "github:vuejs/vue-loader#next", "vue-template-compiler": "^2.5.16" }, babel.config.js module.exports = { presets: [ '@vue/app' ], resolve: { extensions: ['', '.js', '.jsx','.vue'], alias: { "ScrollMagicGSAP": "scrollmagic/scrollmagic/uncompressed/plugins/animation.gsap" } }, module: { rules: [ { test: /\.vue$/, loader: "imports-loader?define=>false" }, ], }, } Error This dependency was not found: * ScrollMagicGSAP in ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/babel-loader/lib!./node_modules/vue-loader/lib??vue-loader-options!./src/views/MarketPlace.vue?vue&type=script&lang=js To install it, you can run: npm install --save ScrollMagicGSAP Can someone help me fix this. I assume i am missing on some package to import.
×