Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

timaging

Members
  • Posts

    250
  • Joined

  • Last visited

Everything posted by timaging

  1. ok, so I did just a bit more renaming, and change the end of any variable name to not have a number. In addition to that, I've added replay:0 to all timelineMax setups. CURRENTLY it appears to be working, but I'm passing it off to the client for further review. Fingers Crossed- Dave
  2. I just tried using PREEXISTING for the Overwrite Manager and now I'm getting a stack overflow, but it doesn't tell me how to fix it, and it crashes IE on my PC. I get a runtime error.
  3. I'm not sure if this makes a difference, but I only import this information on frame 2, so if I'm stopping the timeline, would I in fact need to have this at the top of every frame? import com.greensock.*; import com.greensock.easing.*; import com.greensock.plugins.*; import com.greensock.OverwriteManager; TweenPlugin.activate([VolumePlugin, MotionBlurPlugin, TintPlugin, BlurFilterPlugin, EndArrayPlugin, ColorMatrixFilterPlugin]); import flash.media.Sound; import flash.media.SoundChannel; OverwriteManager.init(OverwriteManager.AUTO);
  4. ok, so I've gone through and renamed all my variables and functions. Nothing has a chance of being duplicated any more, so that doesn't appear to be the issue. It's almost as if the timeline from the frame I'm leaving doesn't stop and somehow remains running. I do however have a stop in each button to tell the associated timeline to stop, and these too are uniquely named: function fl_ClickToGoToScene0516(event:MouseEvent):void { timelineOverview01Out.stop(); MovieClip(this.root).gotoAndPlay(16); } then after a while the timeline itself even goes in to a different timing of around 3 seconds when I have it set to 10. absolutely baffled.
  5. today is tear down and rebuild, and simply review all the code. I can't offhand tell what's wrong, but it's not the timeline per se, it's the combination of the button wanting to do something at the same time that the timelineMAX is doing something.
  6. I've noticed on other projects that Flash can have problems with naming things sequentially too, so my first step will be to rename all my functions and variables. Hopefully as I go through each frame, I will also find and clean up any unnecessary code, but I've already done that twice. Sometimes it almost seems too that if you comment something out, it still works. I question the purity of my published files sometimes. Dave
  7. these are great tips... thanks-I'll dig in this weekend! Dave
  8. oh, I know. I just did a bunch of banner ads for american express and had to convert to AS2 even though they told be before I started that I could use AS3. the reason: clickTAG. BUT with that said, I don't know if frame 19 has too much going on, but I'll bet whatever it is could be found there. ALSO just checked my PC and it's running flash play 10,0,12,36 so that's not it.
  9. I wouldn't even know where to begin to do that. This was as simple as I could figure to do it.
  10. this could be the case, but it's also the player that the client uses... corporate policy I guess. I've looked at that code for hours and can't figure it out-what bugs me the most is that I can see it running fine on my machine. All kinds of crazy timing problems when I use IE9 on XP. I'll see if the player makes a difference here, but it won't make a difference for the client that has to use the player that they have.
  11. just in case: http://https://www.yousendit.com/download/bFlIZXQ5Q1JFd2RjR0E9PQ
  12. ok here it is attached (I think... it just uploaded for a long time). You'll have to excuse my "long hand" but it's really the only way I can understand it. and you are correct, it WILL play properly if you move the mouse away from the button, but if you just leave it there it starts acting erratic. I can't reproduced this on my machine, but on an older PC running IE 8 with windows XP it's guaranteed. I know my client is running an older laptop, and I think the same machine specs.
  13. greensock brain scratcher... check out the url below and let me know what you think. I've got a project with an intro. It then goes to a timelineMax section that advances a frame approximately every 10 seconds. Then, if you click on one of those, we will move to another set of frames that have a timelineMAX on them of 30 seconds and if you don't click to see something else, you are sent back to the frames with the 10 second delay. BUT what's happening is that if I click on one of the buttons, and leave my mouse over that button (especially service eligibility-not sure why that one), the timeline just starts randomly timing out and picking a new frame. If I do that with other buttons, I get the same thing but usually not as bad. Any ideas on maybe how to get that button to not do that? http://www.taylorimaging.com/clientArea ... ndex2.html thanks, Dave
  14. no problem. Every time a Solution comes up, I'm going to try and mark it as such for others that are searching (like me)
  15. ok so apparently what needs to happen is to add a stop to the funtion pointing at the variable: function fl_ClickToGoToScene01n(event:MouseEvent):void { timelineNavOut.stop(); MovieClip(this.root).gotoAndPlay(1, "Nav02"); } there appear to be a few other choices, but this is the only one that worked. Dave
  16. ok, so I'm making this interactive piece. It has an intro on one scene. At then end I jump to another scene and "auto play" between sections using timelineMax and a delay... at the end of each of these delays I call a function to do to the next frame as such: var timelineNavOut:TimelineLite = new TimelineLite({delay:10, onComplete:myFunction01}); timelineNavOut.appendMultiple([new TweenLite(button01, 1, {alpha:0, y:57, ease:Quad.easeInOut}), new TweenLite(nav01off, 1, {tint:0x676766, ease:Quad.easeInOut}), new TweenLite(hdr_nav01, 1, {alpha:0, ease:Quad.easeInOut}), new TweenLite(nav01_b01, 1, {alpha:0, ease:Quad.easeInOut}), new TweenLite(nav01_b02, 1, {alpha:0, ease:Quad.easeInOut}), new TweenLite(nav01_b03, 1, {alpha:0, ease:Quad.easeInOut})], 0, TweenAlign.START, 0.1); function myFunction01():void { gotoAndPlay("2"); } THEN, I have the buttons after that, and when I go to another scene without this delay and goto information, it still goes. what I am certain is happening is even though I'm leaving this frame, something is still telling this delay to work wherever I go. Once I click on a button, I just want all the delay information and everything to be "forgotten" and purge that information. with a button: nav01off.addEventListener(MouseEvent.CLICK, fl_ClickToGoToScene01n); function fl_ClickToGoToScene01n(event:MouseEvent):void { MovieClip(this.root).gotoAndStop(1, "Nav02"); } Is this a job for Overwrite Manager? Currently I have it set in frame on of my Intro to AUTO, but it's still not working. Thanks!! Dave
  17. geez... no wonder. I was looking specifically at the Adobe AS 3 sound page, because I never would have thought that just the greensock code would do it. I gotta figure out a way to wrap my head around all this. Just when I think I'm getting the hang of it, something else comes up! thanks again for your help- Dave
  18. I did that too, and for a few hours, but never found the solution.
  19. Carl, this is outstanding. How did you know to find this delayed call information? If I could find this myself, I'd be out of your hair THANKS!! DAve
  20. Hi, I'm trying to get a sound event to play at around 15 seconds. I have the header code in there: import com.greensock.*; import com.greensock.easing.*; import com.greensock.plugins.*; import com.greensock.OverwriteManager; TweenPlugin.activate([VolumePlugin, MotionBlurPlugin, TintPlugin, BlurFilterPlugin]); import flash.media.Sound; import flash.media.SoundChannel; OverwriteManager.init(OverwriteManager.AUTO); var sound:Crunches = new Crunches(); var chompSound:SoundChannel = sound.play(); and I have my sound labelled: and then I have my code in timelineMax: var yourtimeline:TimelineMax = new TimelineMax({repeat:0,onComplete:myFunction}); yourtimeline.insert(new TweenMax(chompSound, 0, {volume:1, delay:15})); I'm reading through the Flash docs and tried to do sound.stop(); but that crashed flash. I don't see a way to set volume to 0. No matter what I do, the sound plays at the beginning. Is there a way to do this? thanks, dave
  21. ok, so we have 2 issues. One is that you have to change that Actionscript publish setting to "Merged in to Code"... it's a TLF text thing. I don't know why that isn't the default setting. Second and most important is that the sound cannot be placed in the timeline. These defeats the volume reduction. Once I removed it, and followed the sample, it worked. THANK YOU for posting that fla sample. I would never have even thought to try that if you didn't post that! Dave
  22. ok, I found something. There's a publishing "feature" in CS5 where you have to change test to be Merged in to code. This alleviated that issue, but I'm not getting the fade. I think it might have to do with the combination of currentProgress Here's the code I'm using in the button... buttonSkipOff.addEventListener(MouseEvent.CLICK, fl_ClickToGoToWebPageS); function fl_ClickToGoToWebPageS(event:MouseEvent):void { yourtimeline.currentProgress = 0.95; TweenMax.to(channel, 1, {volume:0}); } now, maybe it's my imagination, but it appears to start fading very slightly but never fades fully. check out http://www.taylorimaging.com/clientArea/10-PER-049/ click on the skip intro button also, I'm not sure if this makes a difference, but I do have LoaderMax on Frame 1, and all this other code on Frame 2. I tried both checking and unchecking "Export in frame1" on the sound actionscript properties and neither seemed to affect the behavior.
  23. ok, now I see that this works in CS4 and not CS5. I have done my entire project in CS5... is there any way to get this to work in a newer version of Flash? thanks!! DAve
  24. Hi There, This did fix after a reboot. I had plugged in a new firewire cable for my sound and that somehow affected this page
  25. this will also tie in to another request I've had from a client, where they want event sounds to happen at the same time as a tween. I don't see a way that I can do that currently. Is there and documentation showing how I can do this if it's possible? thanks, Dave
×