Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

sandesh

Members
  • Posts

    29
  • Joined

  • Last visited

sandesh's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Hi Jack.... I have been a regular user of LoaderMax. But now what I want is a tile-based loader. I mean I have this big image which is much bigger than the screen. Only the areas which are visible on the screen should load first. This areas may be square areas (say 100x100 pixels) These areas on loaded should display on the screen. Then the areas which are outside the screen should load. Is this possible with LoaderMax. If not can you suggest some other sources. I have seen this kind of loading on the net. Thanks....
  2. I am having my main site folder containing my own classes as well as your com folder. I am using your LoaderEvent class alongwith your other classes such as TweenLite. But I am getting error 1046:Type was not found or was not a compile-time constant:LoaderEvent even though I am importing LoaderEvent in every class i am using. I fail to understand this problem. Pls help
  3. I have downloaded the latest version of LoaderMax and tested it. But the problem still exists....
  4. Hi Jack, I have a 320 x 160 mov file which I converted to an .flv file with 704 x 396 dimensions. Now if I play the flv file independly using Adobe media player, everything works fine. But when I use the VideoLoader class to load and play the file, the Video shrinks to the original 320 x 160 size for a few seconds and then again shows the correct flv dimensions of 704 x 396. I cant see any reason of this problem. In the Video Loader, I haven't used any object parameters expect for autoPlay = true, since I want to play the file as soon as it buffers enough.
  5. Hi Jack, I am currently using your VideoLoader class, but I noticed that there are no video controls? Have you not included with your class ? If not, is it a way to get the video controls for using it with your video loader?
  6. Hi Jack, I agree with you that the 1 pixel border gap is hardly noticeable. But you know, that this is my company project and this has come as an issue amongst other things. So i have to fix it anyhow so that no gap (1 pixel pink border) is visible anywhere. I tried something like this but it didn't work. Increase the bg width by 2 pixels and shift it on the left by 1 pixel. In the AutoFitArea constructor, I tried to define the x property to -1, and define the width by extra 2 pixels (like 1282 instead of 1280) BUT NOTHING WORKS....... PLS HELP Is there a possibility of any cheat ?
  7. Hi Jack, I have come across a few issues when using your AutoFitArea class. I had used your AutoFitArea class for my swf which i am loading it externally. Since the swf contained mask animations, I attached the swf with the AutoFitArea class and set the calculateVisible = true But I see that if the mask animations are extending on the left side (x<0), then it strangely leaves a gap on the left as well as the right side of my parent swf I have also seen this problem when i am using your Tweenlite class in conjuction with your AutoFitArea class. It strangely leaves a 1 pixel gap either on the left or right side or on both sides.
  8. ya..... you are right. i was doing a small mistake.... it works now.... THANKS
  9. Hi Jack, I am loading a image using your ImageLoader and saving it in an array. Now how do i access the url of the imageloader from the array.
  10. Its working. Thanks a lot, Jack....
  11. Hi Jack I am loading a swf in a file. After the loading is complete, i have given a delay of 5 secs. After the delay of 5 secs i am applying a pink colored tint to the loaded swf and then unloading it. The problem i am facing is that the loaded swf contains some masking animations. So when I apply the pink tint, i see a strange red color in the areas where i have the masking on. In the attached files, pls compile the files and then run LoaderMain.swf which will load IndianStyle_anim.swf. Pls note that you will have to copy your 'com' folder in the attached files path, since i couldn't send it through this mail, due to your uploading size limit of 1MB. Thanks
  12. Hi Jack, I have racked my brains enough but can't simply get the solution. I am using AutofitArea class and setting its calculateVisible property to true, still the masked area portion is not working as expected. E.g: If you compile the attached files, the background along with the content should cover the whole stage, but its considering the width and height of the masked areas. That's why you can see blank areas in the right and bottom sides of the player. Pls help. I dont know where i am going wrong. Pls check this code in the as file. Rest ignore _area = new AutoFitArea(this, 0, 0, 1280, 768) _content = new Content this.addChild(_content) _area.attach(_content, ScaleMode.STRETCH, AlignMode.LEFT, AlignMode.TOP, false, 0, 999999999, 0, 999999999, true)
×