Jump to content
GreenSock

JayP

Members
  • Posts

    1
  • Joined

  • Last visited

JayP's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Hi Jack, First off, thanks for all your work. I've been trying to get the AutoFitArea to work, but I'm having a problem. I am trying to attach a MovieClip to the AutoFitArea, but I am getting an error. In just trying to get started, I am using your sample AS3 code from the site, and I keep getting an Error 1047: Parameter initializer unknown or is not a compile time constant. In looking at the sample code I needed to instantiate the 'myImage' to something, so I instantiated myImage to a MovieClip object (linked in my .swc) but I think this is causing a problem. Is there something I am missing about the DisplayObject and what the requirements are for it. I'm just a little confused and could use a shove (or kick) in the right direction. I can see that others are using these classes for Flex projects, but I am not sure what the error means or how to get around it. When I saw the AutoFitArea, I thought this is exactly what I need because one of the downsides of Flex seems to be the scaling of flash assets inside Flex containers. I intended to use the AutoFitArea inside a Flex container so my UI can scale the clip while maintaining aspect ratio. Like I said, I may be misusing the AutoFitArea altogether, so if that is the case, I apologize for wasting your time. Keep up the good work, and thanks a bunch for all you've done already.
×