Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

Design by The Rues LLC

Members
  • Posts

    9
  • Joined

  • Last visited

Contact Methods

Profile Information

  • Gender
    Male
  • Location
    Tennessee, USA

Design by The Rues LLC's Achievements

Newbie

Newbie (1/14)

2

Reputation

  1. OSUBlake/apploud - Is there any headway on this, or is this code available elsewhere? That link is dead.
  2. Ah. Jonathan, that did it. Adding `rotationX:0.01` forced it. Thank you.
  3. Carl - Thanks for the quick response. I am working on an iPad-only project, and, for some reason, the matrix transforms are infinitely faster (even when just used for scale) than the direct use of scale(). I'm not sure why this is, or if this is new to the iOS family, or what, but I wanted to know if there is a way—even on the simplest of animations—to force the use of the matrix3d() css transform instead. I guess I had assumed force3D offered this, but, in the strictest sense, it is, technically using "3d". Thoughts? Frank
  4. Hello! I am trying to figure out why this codepen (included), even though I have told it "force3D: true" in both the set() and to() methods, is not using "matrix3d" for the transform. I can't seem to figure out what the difference is between my codepen and the GreenSock codepen here: https://codepen.io/GreenSock/pen/kingu. Can anyone point me to the difference? Maybe I just keep missing something simple... Thanks, Frank
  5. Diaco - Wait, I just realized that the "triggerLabelEvent" function is no longer firing with the parameter it is supposed to be passed. Instead, "label" is undefined. Not only that, but it appears to fire 6 times in a row at the very beginning, but doesn't fire at all on the button presses. Lastly, the function I had running to create a "-done" label appended at the end of that sequence was commented out, so that events like "red-done" do not fire. All of these are necessary for my application to get correct reporting. When all put together, the order is unpredictable. Are you sure that addCallback() is the correct order of parameters? I had previously thought that, as per the docs, the first param was the function, the second param was the position, and the third param was the array of parameters to be passed to the function, yes? I've put the correct parameter order back in for the addCallback, and now the labels fire and the animation looks correct, but you'll see that the labels fire in an odd order when pressing the buttons for each color to play them out-of-order. http://codepen.io/frankrue/pen/XJJEQd Thoughts? Frank
  6. Diaco - Yes, that did the trick. I'll work this method back into my larger project and let you know if I have any further problems. Thanks! Frank
  7. Hello! I posted once before about a similar problem, and I was able to workaround that problem easily, but this one is a tad different. In the codepen sample I provided, there are 6 color blocks. Each one is animated in its own timeline, and each timeline is then nested in a master timeline. In this master timeline, I set up a pause at the end of each nested timeline, so that playing the timeline only plays one scene (or, in this example, one animation) at a time, then pauses and waits for the user to press "continue". It is also paused at the start, so you must press "continue" to see the first block. In the linear sequence, all is well: run the codepen and press continue at the end of each block's animation and the blocks animate in when and as expected. The following steps, however, cause a problem: 1. Run the codepen 2. Press continue to display the red block 3. Keep pressing continue and finish the sequence so that all blocks are on-screen 4. Press the button labeled "Orange" and see the orange block animate in as expected 5. Press the button labeled "Blue" and see the green block animate in As you can imagine, the blue block should have been the one to animate in. In addition, I am firing events on each block animation's start and finish, and the events fired for step 5 are two start events for the "green" block and 1 finish even ("green-done") for the green block. The "blue" event never fires. I'm at a loss. Anyone have any idea why this isn't working, or what I'm doing wrong? Effectively, having these "jump-to-scene" buttons is crucial for a project, so any help would be very valuable. Thanks, Frank
  8. Carl - Thanks, and thanks for the compliment. This will work perfectly, as it prevents any significant additional workarounds. I always like it when there's a way to do it without a "hack". Haha. Thanks, Frank
  9. I am using TimelineMax to create a sort of comic that the user can step through. At the end of each sequence of animations, I have a label to indicate the completion of a scene, a pause, and a triggerEvent function that lets my application know that we now need user interaction to continue (typically, to display a next button). Unfortunately, when the user clicks the "next" button to continue (which simply calls the play() method of the timeline), the triggerEvent function fires again, because the playhead was paused at that same frame. There are a number of solutions I am considering so that the triggerEvent function doesn't fire on play, but I wanted to first find out from folks here if there is another way I should be approaching this that is more obvious (as is frequently the case). Thanks in Advance, Frank
×