Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

AdObeOne

Members
  • Posts

    41
  • Joined

  • Last visited

Contact Methods

Profile Information

  • Gender
    Male
  • Location
    The Netherlands

AdObeOne's Achievements

Newbie

Newbie (1/14)

4

Reputation

4

Community Answers

  1. It looks like Animate won't do DOM animation. Who will fill this GUI-animation-gap? GSAP?
  2. OSUBlake, thank you for all your assistance. That may well be so, but you continu to ignore that I can't force this quick fix on my clients. I guess inline is the best, although inconvenient option, to avoid the embed problem altogether.
  3. Hello OSUblake, Thank you for your response. The animations I hoped to make were for sale for other websites. So installing a server isn't a solution. I put some animations on my site as a demonstration of the possibilities. Not being able to make the animations behave correctly in all browsers kills this business activity for me. Which seriously damages my business. Kind regards, Ad
  4. Great idea celli. I was thinking the same thing. Edge Animate hasn't been developed since a long time. It's a nice tool to start in animation, but file management and using more than one edge animation on a site meant manually changing files. Very user unfriendly, considering the target users of Edge Animate. Unbelievable that Adobe didn't solve that within the first couple of versions. Then they killed the export option I was used to using, which was a pain. Combining GSAP's power and features with a GUI-interface would be totally awesome.
  5. Hello OSUblake, The console indicates two non relevant errors. A favicon.ico that is not found, but that is displayed anyway. And an include of a css file that is no longer used. So no error messages regarding the use of the animations that are not correctly displayed within iframes on the mobile webkit browsers. Kind regards, Ad
  6. Hello OSUblake, Thank you for your response. So I have to install a server to be able to use the load command instead of iframe, to avoid the problem with webkit mobile browsers. That sounds like shooting with a canon on a fly Thank you for all your time and effort explaining this to me. I hope it benefits more users than just me. I'll get busy with the console. Kind regards, Ad
  7. Hello OSUblake, I didn't see that there was a second page. So I was still waiting. I'm still in doubt regarding my questions. When I use frames my animations are shown. So jQuery is loaded in the correct order. And my paths are correct. Is that correct? If I only replace the iframe by a load command do I need to change anything in the order in which things are loaded or in the paths I use? Is AJAX used when I use the load command? Thanks for you response, Ad
  8. Hello OSUblake, Thanks for your reply. The animations I use are shown when I use iframe. So the order of included files is correct I presume. Or does the load function require another order? All code for the animation is contained within the loaded html-file and the files that are linked to it. I see in the linked example that "ajax" is included in the paths to the files? I use these paths for jquery and use local Greensock files. <script type="text/javascript" src="http://code.jquery.com/jquery-1.10.2.js"></script> <script type="text/javascript" src="http://code.jquery.com/ui/1.11.4/jquery-ui.js"></script> Do I need to change that? Kind regards, Ad
  9. Hello OSUblake, Thanks for the links. As I understand, the html file only contains the assets in these examples. No links to css or javascript within this loaded html file. This is what I use in my index.html: <div id="myContainer"> <script>$("#myContainer").load("folder/myAnimation.html")</script> </div> My site is like a shop window. I (very) regularly change parts of the content. The content are examples of what I can do for potential clients. For easy maintenance I like to keep an animation as a self contained unit within the page code and within the file structure. So it loads it's own css and javascript file(s). And all files for the animation are within one folder. The correct amount of space is created for my animation. So this partially works. But no animation is shown. Is it necessary for the solution that you suggest that there is a function call as part of the load command to a function that contains the animation commands? Kind regards, Ad
  10. Hello OSUblake, The correct amount of space is created (width and height) using the load command, but nothing is shown of the loaded html-file. I can't find any information about how to accomplish that. Can you tell me how I make the loaded file visible? Thank you in advance for your help, Ad
  11. @Carl I don't know how to put it simpler then this (quote from a previous post): " Short: do you have a solution to make an animation scale responsively within a webkit mobile browser window? " And there is a bare minimum example attached to one of my previous posts on this topic. I'll try OSUblake's solution, using a separate file, because of maintainability. If this does not solve the problem then I'll take the Stackoverflow route you suggest. @OSUblake Thanks for your response. I'll try the load option. I don't like the inline option, as I replied to Jonathan. I like to split up large chunks so I can more easily keep an overview. I'll let you know if this solves the problem.
  12. Two weeks since the previous post on this topic. No new response. So no one but me has a problem using Greensock animations scaling responsively on webkit mobile browsers? Please let me know. Which solution did you use to make this work?
  13. Hello fellow Greensock user, Short: do you have a solution to make an animation scale responsively within a webkit mobile browser window? Longer: I've managed in the meantime to try the CodePen solution and the resizable JQuery option. Before that I tried the FitVid solution and a couple of other 'solutions' that I found on forums. But non of them work. To see what I mean in context, please use a webkit mobile browser to visit: www.nieuwjaarverslag.nl. There are two animations and one interactive piece of content that are only partially visible. I would very much like to be able to correct that. Any help is deeply appreciated, Ad
  14. @Jonathan: Strange. It worked just fine. But now it doesn't anymore. Not even in CodePen @PointC: Thanks for your scarce time and the side by side pen. Very handy to see the differences. That sure helps @Acccent: Thank you for the extensive explanation and the second attempt. I hope you not only helped me, but others as well.
  15. Hello Carl, I thought a private pen would still be accessible aslong as I provided the link. Just not that others could find it. My mistake. I've made the pen public. Thanks, Ad
×