Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...

deloki

Members
  • Posts

    3
  • Joined

  • Last visited

Recent Profile Visitors

2,136 profile views
  • kek

deloki's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. I am trying to use the transform around centre with starling TextField instance but i keep getting this error: [Fault] exception, information=TypeError: Error #1009: Cannot access a property or method of a null object reference. I am activating the plugin before use like this in the class that i am using it: TweenPlugin.activate([TransformAroundCenterPlugin, TransformAroundPointPlugin, ShortRotationPlugin]); And then i am trying to execute this code: TweenLite.to(_textField, _animationDuration ,{transformAroundCenter:{scaleX: 1.2, scaleY: 1.2},ease:Elastic.easeOut}); Is this a known issue with starling or am i just forgetting something. EDIT: Actually i can't get the plugin to work at all, even with the displaylist
  2. To give some more info, the app doesn't break, if i disconnect the debugger before touching the BlitMask, the app will continue to run as it should. Also it seems that the problem happens only when i turn off bitmapMode. I think the problem comes from setting cacheAsBitmap to true in an object that i am putting the BlitMask on, and then setting the bitmapMode to false in BlitMask. When bitmapMode is on in the blitMask, the problem will not appear. It is pretty easy to replicate, if anyone wants to take a look
  3. I am getting this weird error trying to use BlitMask when debugging on my android device: Error #2030: End of file was encountered. And it is coming from this part of the BlitMask code, on TOUCH_BEGIN event (when i put my finger down on the BlitMasked object): /** @private **/ protected function _mouseEventPassthrough(event:Event):void { if (this.mouseEnabled && (!_bitmapMode || (event is MouseEvent && this.hitTestPoint(MouseEvent(event).stageX, MouseEvent(event).stageY, false)))) { dispatchEvent(event); } } When debugging in emulator, the error does not happen, only when debugging on device. Does anyone know how to fix this issue?
×