Jump to content
GreenSock

MarcusDobler

transformAroundPoint ios

Recommended Posts

I have a crazy issue with "transformAroundPoint" my Code works perfect on iOS Xcode Simulator. But when I run the same thing on my iPad I get Errors! I never have seen any different behavior simulator vs. device. I hope anybody can help me...  

 

It also makes no difference if I don't do any scaling in transformAroundPoint always the same errors.

 

S O U R C E C O D E >>>>

 

.....

 

TweenPlugin.activate( [TransformAroundPointPlugin] );
 
Multitouch.inputMode = MultitouchInputMode.GESTURE;
 
this.addEventListener( TransformGestureEvent.GESTURE_ZOOM, pointZoom );
 
}
 
/** Zoom */
 
private function pointZoom( _event : TransformGestureEvent ) : void
{
 
trace("zoom");
 
var _transformPointX : Number = _event.stageX;
 
var _transformPointY : Number = _event.stageY;
 
/**/
 
var _scale : Number = _images[ _activeImage ].scaleX * _event.scaleX;
 
var _myPoint : Point = new Point( _transformPointX, _transformPointY );
 
/**/
 
TweenLite.set( _images[ 3 ], { transformAroundPoint: { point: _myPoint, scale: _scale } } );
 
}
 
<<<<
 
E R R O R S  O N  I P A D >>>>>
 

Exception fault: TypeError: Error #1006: value is not a function.

at com.greensock::TweenLite/_init()[/Active/_Flash/_AS3_v12/src/com/greensock/TweenLite.as:559]

at com.greensock::TweenLite/render()[/Active/_Flash/_AS3_v12/src/com/greensock/TweenLite.as:703]

at com.greensock::TweenLite()[/Active/_Flash/_AS3_v12/src/com/greensock/TweenLite.as:488]

at com.greensock::TweenLite$/set()[/Active/_Flash/_AS3_v12/src/com/greensock/TweenLite.as:1094]

at com.ponyhof.gallery::GalleryZoomNew/pointZoom()[/Volumes/Work/Development/Projects/WordPress/src/com/ponyhof/gallery/GalleryZoomNew.as:431]

at com.ponyhof.gallery::GalleryZoomNew/pointZoom()

 

Link to comment
Share on other sites

Hmm, that's tough to diagnose blind, but it almost seems like you've got mixed versions of some of the core files loaded, like a newer version of TweenLite with an old version of TweenPlugin. Please make sure you recompile all your files with the latest versions of the GreenSock files. If you're still having trouble, please create a simplified reduced test case that demonstrates the issue and upload the file(s) here so that we can publish on our end (don't forget to zip the files first). 

 

Another possibility is that Adobe is doing something strange in terms of the instantiation order of the classes when compiled for iOS. Make sure you've got the latest Adobe stuff too. 

 

Do you get the error if you remove the transformAroundPoint stuff and instead use a different plugin? In other words, is the error definitely related to TransformAroundPointPlugin only? 

 

Also, have you tried specifying scaleX and scaleY instead of only using a "scale"? 

  • Like 1
Link to comment
Share on other sites

Hi, thank you for the answer! I haven't used the source I have used the .swc and the error seems to be in the .swc file. If I use the source code and place it in my project everything works fine?

 

Can you place a new .swc file in the bonus-all folder?

Link to comment
Share on other sites

Absolutely - I re-compiled the .swc and uploaded a new bonus.zip. Please let us know if that works well for you. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×