Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
friendlygiraffe

alpha flicker

Recommended Posts

Hi 

 

I am having a problem with a movieClip flickering when using a from autoAlpha function

TweenMax.from(mc), 3, {autoAlpha:0});

This works fine when publishing a preview, but when a standalone is created, you get a flicker of the mc at full visibility. 

 

Is there any way round this? I don't want to have to physically set the alpha to 0 using the properties panel then fade it in to autoAlpha:1

 

Thanks

Link to comment
Share on other sites

First, you've got a typo (and extra ")") in your code. I think you meant:

TweenMax.from(mc, 3, {autoAlpha:0});

And yes, Flash loads the first frame assets, then once they're all loaded, it'll fire the ActionScript on that frame. So if your mc is at full opacity sitting on the stage, it'll load that way, and then when Flash fires the ActionScript and allows TweenMax to do its thing, it'll make the alpha jump to zero and fade in. That's not a bug or a problem with TweenMax - it's simply how Flash works and loads things. 

 

You can either move everything to frame 2 instead of frame 1, or you can set the object's alpha to 0 in the properties palette. I don't see any other options. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×