Jump to content
GreenSock

Marko

Publish in HTML doesn't start animations

Recommended Posts

Might be a Flash question, but still, since all the animations are done with TweenLite (fabulous library, btw), I'm asking here.

 

When I publish my animation (swf and html) and open it in IE, the animation doesn't start. I can see only the first frame, but if I open .swf in Windows Explorer, everything works fine.

 

I have three layers in Flash - one with actionscript and two with symbols. Only one frame exists, since everything is done in AS.

 

Thanx to anyone for answering...

Link to comment
Share on other sites

Very strange. Which version of IE? Is it only 1 version?

 

Have you tried removing TweenLite and trying other scripted animation like

this.addEventListener(event.ENTER_FRAME, move)

function move(e:Event):void {
  someMC.x++;
}

Please provide all details OS and IE version and a simple file we can test, if there's something we can do, we'll let you know. Seems very unlikely that there is something in TweenLite that is amiss.

Link to comment
Share on other sites

It's probably not Flash's fault, since it's the samo in Mozilla and Chrome - on other machines as well.

I'm pretty sure that I'm missing something in the AS.

 

I've attached a simple animation (rename it to .fla) that I'm having troubles with; If you'll have the time to take a look, I'll much appreciate it.

 

I'm actually building a screen saver - when I build it with InstantStorm of course it doesn't play, so I figured if it is going to play in IE, it's gonna play in screen saver as well.

test.fla.txt

Link to comment
Share on other sites

SOLVED!

It was the AS, but it was the first line that was causing this behaviour. A rooky mistake I would say.

 

The first line was changing into a full screen mode, which is not supported in browsers unless a users sends/clicks a command/button.

 

Thank you anyway for the quick replies!

Link to comment
Share on other sites

Take a look at:

http://help.adobe.com/en_US/ActionScript/3.0_ProgrammingAS3/WS2E9C7F3B-6A7C-4c5d-8ADD-5B23446FBEEB.html

 

lol, yeah, I just found the same thing. This will work

 

//click on stage to activate full screen

stage.addEventListener(MouseEvent.CLICK, goFullScreen);


function goFullScreen(e:MouseEvent):void {
stage.displayState = StageDisplayState.FULL_SCREEN
}

Glad you figured it out. Thanks for the update!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×