Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
tomihr

Problem loading SWF

Recommended Posts

Hello,

 

I have strange problem loading swf file, in the preloading event most of the time the preloading progress value isvery small and then after 2/3 of loading progres speed up.

On the server when I multiply the number with 100 and rount the walue I got 0% all the time and then it jumps to the 100%.

 

private function onLoadingProgress(event:LoaderEvent)
{
 percent_num = Math.round((event.target.bytesLoaded/event.target.bytesTotal) * 100);
 parent_class.mainPreload.progressData(percent_num);
}

Link to comment
Share on other sites

Hi! and Welcome to the GreenSock forums.

 

That seems a bit odd. Hard to tell what could be wrong from just the code you provided.

Have you tried replacing the SWFLoader code with just a regular AS3 Loader? Perhaps this would reveal if there is something inherently wrong with your swf, server or something else in your environment.

 

If you are pretty sure the SWFLoader isn't behaving properly, simply create a simplified version of your files that we can use to test and replicated the issue. Doesn't have to be your production files or anything fancy, just something that will illustrate the inconsistent progress. Please zip your files before trying to attach them to a post.

 

We'd love to help you sort this out.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×