Jump to content
GreenSock

MarioLapone

TimelineMax And rotationX/Y problem

Recommended Posts

I've a strage problem with displayObject (sprite or movieclip).

These objects are created and added on stage by a program and then manipulated by timelineMax.

When objects are rotated with a 3d rotation (rotationX, rotationY) they are "deformed" after timeline starts by other objects that move over or above them (collision).

 

The following link shows the image before the "error"

http://www.attivitac...ini/gError1.jpg

 

...then the same image after timelineMax is started

http://www.attivitac...ini/gError2.jpg

 

Does someone know something about this behavior?

Link to comment
Share on other sites

Hi,

 

Sorry to hear you are having problems. The problem most likely lies with Flash as opposed to TimelineMax. Although I haven't seen that often, Flash is known to choke when animating large bitmaps. Seems that something is getting out of sync with frame renders.

 

Really hard to diagnos without having a file to test. Does this happen consistently? Are your displayObjects really really big?

 

If you want to post a really simple file that can replicate the issue, we will take a look at it.

 

Carl

Link to comment
Share on other sites

Thank you for your replay.

Well it's very difficult to explain the contest of the problem. But i try (the code it's long and complicate yet, but it has not strange solution - i hope that in a week i can send you something).

 

Image something like a fileSystem with folders and files where folders are symbols/containers (a sprite extension class) and files are objects like shapes, texts, images, videos etc.

For example

 

-container1

---container11

------container12

---------container13

------------Shape

------------Image (*)

------------Video

-conatainer2

-conatainer3

 

The image with * is "our" image with ".rotationX = 20"

Well, when a timeline starts we have the error.

The same happens in the following two structures

 

-container1

---container11

------container12

---------Image (*)

---------container13

------------Shape

------------Video

-conatainer2

-conatainer3

 

-container1

---container11

------Image (*)

------container12

---------container13

------------Shape

------------Video

-conatainer2

-conatainer3

 

But IT DOES NOT HAPPEN with this one

 

-container1

---container11

------container12

---------container13

------------Shape

------------Video

---Image (*)

-conatainer2

-conatainer3

 

And it happens with small images or shapes too.

 

If i apply the rotationX to the video all is the same (change "image" with "video"), but only from the second time that timeline runs (not the first one). Video blades everytime an object moves over or above it.

 

I tried a lot of solutions (e.g. the timeline modifyies 2d props for an object and 3d props for its container or viceversa) but without success.

 

I am afraid that is a flash problem.

Thank you again.

 

Mario

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×