Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Piotr

Issue with loading swf's which are using greensock into by flex 3 projects

Recommended Posts

Hi.

 

We have some problems with loading external swf's which are using greensock tweening by swf created in Flex 3. Basically we are trying to load some swf which is using greensock tweening into SWFLoader or Image components. Everything works fine, except that animations aren't being run. Initially we thought it may be related to application domain or frame rate - no luck here. To be completely sure, we created new empty project in Flex 3 and loaded swf locally - the issues still appeared.

 

Is it some kind of known issue?

 

Regards.

Link to comment
Share on other sites

I have never heard of this sort of thing before, and it sounds like there may be some other issue at play - can you please post a very simple Flex project or FLA that we can publish on our end to see the issue reproduced? It's very difficult to troubleshoot blind. I'm sure we can get it figured out once we see what's happening and can add trace() statements, etc.

Link to comment
Share on other sites

Oh, it looks like the problem is that you're using an Image component and trying to load an swf into it. An Image is for loading images like jpg or png files. You need an SWFLoader. I'm not really a Flex expert by any means (I try to avoid it at all costs because of all the bugs and overhead), but I'm pretty confident that your problem is indeed that you're using an Image instead of SWFLoader (or a similar swf-loading component).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×