Jump to content
GreenSock

arno

installing LoaderMax

Recommended Posts

I have downloaded the full LoaderMax package and I have tried to launch the demos contained within the package but I get error messages each time I try to edit one of the fla or as file. it says mostly :

error " 1046: Type .... not a compile-time constant: ContentDisplay.

 

It is very frustrating not being able to go anywere from that point. Please help !!

post-10938-0-54855800-1334867924_thumb.png

Link to comment
Share on other sites

It sounds like maybe you have a corrupt Flash install or something. Maybe your decompression engine didn't fully unzip the files? I'm not sure because I just downloaded the files again and they published perfectly for me. No errors at all.

 

Can anyone else replicate this problem?

 

If you're still having trouble, please zip up a directory containing your FLA and the GreenSock files and post them here so that we can try publishing on our end.

 

Where are you getting your files, by the way?

Link to comment
Share on other sites

post-10938-0-04782100-1334947249_thumb.pngpost-10938-0-04782100-1334947249_thumb.pngWell thanks for you reply. I have just downloaded the greensock as3 package again as i did yesterday but the files included are surprisingly not the same which is quite puzzling. Unfortunately i put the previous package in my bin and deleted it before downloading again so this cannot help much. I have attached a screenshot of the actual files I have now. The version I had yesterday got much more files like the fla. ones which have vanished since !!
Link to comment
Share on other sites

I'm as baffled as you are - maybe you got the old set of files from elsewhere (not on greensock.com)? Very tough to say. I have never included any .fla files in the main downloads. Maybe you were looking at the demo files from the "Intro to LoaderMax" video series from Rich Shupe? http://www.greensock.com/loadermax-video/

Link to comment
Share on other sites

I'm sure that I did download the file from greesnock. I clicked the download As3 button on the top right corner. And I opened the fla files which were included but that I have unfortunately deleted them since. I did have a look to the demo files too but did not get any files from that link.

You can see on my first attachment that I had some of the fla files opened in Flash API.

 

I have also tried to open the demo swfs in the new package but then I get a message saying that I cannot open a file which is protected.

Is that normal ? Thanks for your reply.

post-10938-0-98902100-1335123477_thumb.png

Link to comment
Share on other sites

Maybe you mistook the .swf files as .fla files? Like I said, there have NEVER been .fla files included in that public download you referenced. And a .swc is a very different beast altogether - were you trying to open that in Flash? That's not what an .swc file is for.

 

The .swf and .swc files are not to be opened in the Flash IDE. .swf files are to be run in the Flash Player and the .swc file is for compiling (it's like a precompiled package of the classes - feel free to Google .swc for more info). Make more sense now?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×