Jump to content
GreenSock

senortaco

'prevNode' error, using AS2 MotionBlur plugin

Recommended Posts

Hi,

 

I just purchased a club greensock membership, hoping to use the motion blur tool (AS2), but with tweenlite, it doesn't seem to work, and with tweenMax I got this error message:

"There is no property with the name 'prevNode'. (in RoundPropsPlugin.as)

 

import com.greensock.*; 
import com.greensock.easing.*;
import com.greensock.plugins.*;
TweenPlugin.activate([MotionBlurPlugin]);

b.onRelease = function(){
 TweenMax.to(mc, 0.5, {_x:_xmouse, _y:_ymouse, motionBlur:true, ease:Cubic.easeInOut});
}

 

Many thanks

Link to comment
Share on other sites

Hmm...there must be something else going on in your file or maybe you have mix-matched versions of various GreenSock classes. I just tested your code and it worked perfectly for me. No errors whatsoever. And nobody else has reported something like this - that's why I suspect it's something on your end. Would you try downloading the bonus zip again and make sure you're using those classes instead of any older files you might have had laying around? And if that doesn't work, please post a simple FLA that demonstrates the issue so that I can publish it and see the error(s).

 

You are publishing to Flash Player 8 or later, right? That's necessary for the BitmapData stuff that's used internally.

Link to comment
Share on other sites

Yep, you were right. I had a copy of the standard GS library in the same directory as the FLA in question. Case closed.

 

Thanks heaps for your time - and for making an awesome product.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×