Jump to content
GreenSock

Dave Stewart

"autoAlpha not found on xx" runtime errors after v11 upgrade

Recommended Posts

I'm getting the following errors (all the same on all objects) regarding autoAlpha throughout my project after upgrading from v8 to v11:

 

ReferenceError: Error #1069: Property autoAlpha not found on flash.text.TextField and there is no default value.
at com.greensock::TweenLite/init()
at com.greensock::TweenLite/renderTime()
at com.greensock.core::SimpleTimeline/renderTime()
at com.greensock::TweenLite$/updateAll()

 

Can anyone suggest where to start looking before I dive in to debug?

 

Thanks,

Dave

Link to comment
Share on other sites

Yep, you forgot to activate the autoAlpha plugin. As indicated in the release notes (http://www.greensock.com/v11/), TweenLite does NOT activate any plugins by default because one of the primary objectives of the class is to minimize file size. In prior versions, there were about 7 plugins that were automatically activated (including autoAlpha). All you need to do is add this code once in your swf:

 

import com.greensock.plugins.*;
TweenPlugin.activate([AutoAlphaPlugin]);

 

Feel free to use the Plugin Explorer to write the activation code - all you need to do is select the plugins you want to activate and it'll write the code for you down below.

Link to comment
Share on other sites

Ah: "Important changes ("gotchas" to watch out for when switching from v10 to v11)", jolly good!

 

Sorry I missed that. I know what a pain it is when you write lots of docs then people miss the stuff you set out to make easy.

 

Cheers,

Dave

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×