Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Bradley Lancaster

CPU Usage & Performance Tools Used to check and validate HTML5 ads

Recommended Posts

Hey guys,

 

So i have encountered some feedback from a publisher that the HTML5 banners i created were using to much CPU.

 

I don't have a way to check this properly i looked in Chrome Dev tools and can only see GPU there.

Activity monitor was only 8% but they were saying it comes in @ 60% which i find hard to believe.

 

I can't upload them here yet as the campaign hasn't launched but i will soon.

 

Do you guys have a set of tools/programs you use specifically for CPU performance.

 

They are using https://advalidation.com we are getting pricing on this but i would prefer a free or cheap method.

 

Cheers,

Brad

Link to comment
Share on other sites

Sorry to hear about the trouble, @Bradley Lancaster. I don't have any specific tools outside Chrome's dev tools and watching the frame rate and I think there are some CPU usage things there too, but it's tied to your particular system. In other words, it might be 8% on your powerful system, but on a cheap phone it's 90%. It's all relative. 

 

I'm curious - do your banners use SVG? That can be pretty CPU-intensive to render. 

Link to comment
Share on other sites

Hi Jack,

 

Thanks for getting back to me on this.

 

I have attached a file here for you to have a look at if you have time. It does use a combination of png's and svg's and some canvas particles. I removed the bubbles for them but they still came back with CPU issues so i don't think it is related to the bubbles.

 

I sent another version removing the will-change property but still they said it's a high CPU load.

 

I use SVG's normally and haven't had this issue before but it is all dependant on the Publisher  and how they test things.

 

Cheers,

Brad

300x250_parallax.zip

Link to comment
Share on other sites

I don't really have time to pull it all apart, but I don't see anything obviously "wrong". You might want to try removing the canvas stuff (just for testing), especially the globalCompositeOperation = 'lighter'. It also looke like you've got a bunch of calls to particleTwo() and some drawing stuff that might be slightly problematic (not sure). I'd be curious about removing your calls to drawTwo() just to see how that affects things. 

  • Like 1
Link to comment
Share on other sites

Thank you for checking that out for me.

 

Yes i did take out the bubble functions completely the publisher came back with the same thing. I think the tool is possibly testing things incorrectly i will try gain access to the tool and see.

 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×