Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Catalin R.

ScrollMagic and ScrollToPlugin

Recommended Posts

Hi everyone,
I have an issue in ScrollMagic.
I'm interesting in to find if somebody discovered the same issue.

I want to have the same effect on scroll like on the link below.

See the last codepen on this link: 


The plugin reacts instantly on window, on scroll, but on a container has a delay of ~0.5s, only on Internet Explorer.
Can anybody explain this?

Link to comment
Share on other sites

My gut says this is a delay (in IE) with the handoff of the scroll event from the window to the overflowed container. I'm not entirely sure of that, but I would suspect it.

  • Like 2
Link to comment
Share on other sites

I'm not sure I understand the problem however...

 

If you mean this pen, there is a 0.5s delay on the text animation. If that's what you're refering to, remove it and it will fire at the same time as the silde animation.

 

Though I think you may mean something else as this has nothing specifically to do with IE.

 

See the Pen NywvGp by Visual-Q (@Visual-Q) on CodePen

 

  • Like 2
Link to comment
Share on other sites

On 2/27/2018 at 11:52 PM, Visual-Q said:

I'm not sure I understand the problem however...

 

If you mean this pen, there is a 0.5s delay on the text animation. If that's what you're refering to, remove it and it will fire at the same time as the silde animation.

 

Though I think you may mean something else as this has nothing specifically to do with IE.

It's not about text animation. The next section starts with some delay on scroll.

 

See the Pen NywvGp by Visual-Q (@Visual-Q) on CodePen

 

 

Link to comment
Share on other sites

It's not about text animation. The next section starts with some delay on scroll. Only in IE.

Link to comment
Share on other sites

Unfortunately I don't have a windows box to test it on at the moment. I think I saw you had posted on the scrollMajic forum. You might want to fork the pen and add it to your post so people understand the problem.

 

There is a small offset on the trigger to prevent it from being hypersensitive, possibly IE is interpreting this differently from other browsers you could try playing with that number. 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×