Jump to content
GreenSock

Webls

IOS - Draggable stop working when leave video fullscreen

Recommended Posts

Hello all,

 

I am working with draggable plugin to create a carousel which includes one (or several) HTML5 video inside each pane.

 

I found an issue on iphone  (iOS 9, 10+) devices when user goes to fullscreen for video and then exit fullscreen.

 

As you will see in the example below, when you leave fullscreen on iPhone, drag stop working.

 

 

The fix I found, (which is not a fix by the way!) is to add a "touchend" event in order to call Draggable.endDrag() which bring back the scroll (but it means you need to drag once to be able to scroll after ! (I tried to call startDrag en "touchstart" event but it didn't work.

 

 

The best way would be to call Draggable.dradEnd() when video exits fullscreen but as we cannot listen to video enter/exit fullscreen on iOS, it is not possible :(

 

 

I noticed that if i remove the viewport meta tag, drag works perfectly after exit video fullscreen, but same, it is not a solution.

 

Do you have any idea how to fix that ?

Thanks !

 

Issue can be reproduced here  :

 

http://codepen.io/webls/pen/WREarq

 

 

See the Pen WREarq by webls (@webls) on CodePen

Link to comment
Share on other sites

Hello Webls and Welcome to the GreenSock Forum

 

We are sorry you are having this issue!

  • What iOS version are you using?

To make it easier for use to debug this, can you please convert your example to a limited codepen demo example?

 

This way we can test your code live in an editable environment.

 

 

Thank You! :)

  • Like 2
Link to comment
Share on other sites

Hello Jonathan,

I created the codepen, available here :

See the Pen WREarq by webls (@webls) on CodePen

 

The issue can be reproduced on Safari, iOS9, 10+ on iPhone and iPad

 

Thanks.

Link to comment
Share on other sites

Hi again,

do you have any idea how I can fix that issue ?

 

Thanks for your help.

Link to comment
Share on other sites

Hello Webls, Please standby while we look into this.

 

And thank you for creating the codepen! :)

Link to comment
Share on other sites

  • 3 weeks later...

Hi all,

does anyone got this issue before ?

 

Thanks a lot.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×