Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
gibbz

Air Desktop - AS3 code ignored on loaded SWFs

Recommended Posts

Hi! We have a problem with LoaderMax: an Air desktop application should load some SWFs from a folder.
When this folder is under ApplicationDirectory everything is ok.
When the folder containing the SWFs is placed on user desktop, the AS3 code on loaded SWFs is not executed.
The runtime seems to execute only the as3 code contained in the last loaded swf. No errors are thrown.

We provide a sample Flash Builder project to demonstrate the issue. There are 2 buttons:
clicking the first button the swfs are loaded from application directory. Clicking the second button the swfs are copied on a desktop folder and loaded from there.
With the second button, the stop() and trace statements are ignored, and the loaded swfs will loop.

A few notes:
The issue occur only when loading 3 or more swfs.
The swf have nested MovieClips, that are NOT present on first frame. If the nested movieclip are always present on the main timeline, the issue do not occur.
The FLAs of the SWFs are provided in the sample project.
The Air runtime is the latest, 19.0.0.213, old compiler
The GreenSock swc is the latest, version: 12.1.5, updated 2015-03-25

 

Thank You for your help!

 

Sample project link:

https://www.dropbox.com/s/l986qrvtl6bl8xs/LoaderMaxTest.zip?dl=0

Link to comment
Share on other sites

Sorry to hear you are having problems.

This is very strange and I'm extremely doubtful that LoaderMax is preventing your script from executing. 

Please replace the LoaderMax code with a native AS3 Loader as its important to first understand if this has anything to do with LoaderMax.

 

Our support for LoaderMax (especially with AIR) is extremely limited. We haven't updated LoaderMax in a few years and we only investigate critical bugs at this point. It sounds like you can alleviate the issues by placing your MovieClips in the first frame of your loaded swfd, perhaps offstage or with visibility:false. 

Link to comment
Share on other sites

Hi Carl, Thank You for your reply!

We have resolved the issue. It's a security-related problem, not related to LoaderMax. More info:

http://richardleggett.co.uk/blog/2009/04/02/loading-swfs-into-air-1-5-and-loaderinfo/

 

While publishing the external swf from Flash Pro, setting the Publish Settings->Local playback security to "access network only", resolve the issue.

Link to comment
Share on other sites

Glad you got it figured out and thanks for posting your findings. Always good to have solutions for folks to see.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×