Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
tqnhat

onComplete not fire

Recommended Posts

Hi all,
 
I have a banner which is put in a website.
If I put it in header(visible view of website) -> work perfect.
If I put it in a footer and we don't see it at the first time. When I scroll
down, banner don't play like the way I want. 
I have a movieclip named "book", it's have two "stop();" inside.
It seem "onComplete" just fired once when banner is in invisible view of website.
 
Is this a bug of TweenLite or I do someting wrong?
Thank you for your help.
function playIt(evt:Event=null){
book.play();
}
function anim(){
TweenNano.to(txt1, 1, { alpha:1, delay:.1 });
TweenNano.to(txt2, 1, { alpha:1, delay:1 });


TweenNano.to(book, 1, { x:152, y:167, rotation:16, delay:3, onComplete:playIt});


TweenNano.to([txt1,txt2], 1, { alpha:0, delay:10 , onComplete:playIt});


TweenNano.to(txt3, 1, { alpha:1, delay:10 });
TweenNano.to(txt4, 1, { alpha:1, delay:11 });
}

 

Link to comment
Share on other sites

Hi and welcome to the GreenSock forums.

 

I haven't ever heard of a flash movie not playing based on where it is on an html page.

I really can't tell anything from the code you provided other than you aren't showing that where the  anim() function is actually called to run.

 

Have you tested multiple browsers? which browsers display this behavior?

 

It would really help if you could provide a super simple fla and HTML page that clearly illustrates this behavior.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×