Jump to content
GreenSock

ebhoren

TweenLite bug in AIR 15.0

Recommended Posts

I'm having a strange issue with Tweenlite running on AIR 15.0.

Previously, the same code worked correctly in AIR 3.7 when compiled from both Flash Builder 4.7 and my custom Ant script.

 

Now, i'm having this error message when trying to compile my application using my Ant script.

[Fault] exception, information=ReferenceError: Error #1069: Property _isGSVars not found on Number and there is no default value.
Fault, _prepVars() at TweenLite.as:1029

The problem does not occur when compiling my app from Flash Builder 4.7.

I can't figure why it work when compiled from Flash Builder 4.7 and not from my Ant script, who previously worked perfectly.

 

 

Anyone have faced this problem before?

Thanks

Link to comment
Share on other sites

That error sounds like there's a problem in your code where you're passing a number in as the "vars" (which should be an object). For example:

//BAD:
TweenLite.to(obj, 1, 2);

//GOOD: 
TweenLite.to(obj, 1, {x:100});

Tough to know for sure without seeing a reduced test case, but it sure looks like that's the problem. 

  • Like 1
Link to comment
Share on other sites

That's the problem. The exact same code works in AIR 3.7.

Any ideas?

Link to comment
Share on other sites

Very difficult to troubleshoot blind. Like I said, it sounds like you've got a number being passed in as the vars object somewhere. Perhaps AIR 3.7 handled that differently, although I couldn't tell you why. Perhaps reach out to Adobe. If I were you, though, I'd try to isolate the problem in a simplified FLA so that I can get clarity on exactly what's going on. 

Link to comment
Share on other sites

I've figured what the problem is.

The problem is with the ADT compiler in AIR 15.0.0.249. AIR 14 enabled a new "fast compiler" mode which compile your Actionscript code in a better way, which speeds up compilation time and application performance. This new "fast compiler" mode was disabled by default in AIR 14. You can enable it by adding -useLegacyAOT no to your ADT compilation script.

 

See more details here: http://www.adobe.com/devnet/air/articles/ios-packaging-compiled-mode.html

Unfortunately, this is some know bugs by Adobe: http://helpx.adobe.com/air/kb/unable-update-air-mac-os1.html

 

In AIR 15.0, they enabled by default this "fast compiler" mode. That's why my Actionscript code didn't work when compiled with AIR 15.0. I disabled "fast compiler" with AIR 15.0 and everything worked perfectly :)

 

Hope it will help other people.

Thanks

  • Like 2
Link to comment
Share on other sites

Excellent, thanks for sharing your findings.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×