Jump to content
GreenSock

Search In
  • More options...
Find results that contain...
Find results in...
Impirator

Bug: opacity is ignored in IE8 when 'x' property is present

Recommended Posts

CodePen (I don't think this site supports IE8, so this may not be useful): 

See the Pen kxhfD by anon (@anon) on CodePen

 

Problem

Opacity isn't animated when there is an x-translation in Internet Explorer 8.

 

Code

// no opacity animation in IE8, works in modern browsers

var element = document.getElementById('box');
var animation = {
  x: -50,
  opacity: 0
};

TweenMax.from(element, 1, animation);

a

Extra note

If you replace the x with marginLeft, the opacity correctly animates.

 

 

 > Thank you so much for all the hard work, guys.  It's really, really appreciated. <

Link to comment
Share on other sites

Hmm...I just tested your code and it worked great for me in IE8 with the latest version of GSAP. Maybe you're using an old version? And are you using the "real" IE8 or some emulator? Emulators are known for rendering things wrong :)

Link to comment
Share on other sites

Thanks for the prompt reply!  I was in fact using IE's debug tools to put it into IE8 mode, so I'll bet that's what it was.  Sorry to make waves over nothing!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×